LINUX DOTNET      Linux DotNET 中文社区

Linux .NET编程与应用技术之专业网站:www.linuxdot.net !     返回首页    
   
[楼主] Jexus V2.1是否能运行 .net3.5 程序?

Jexus V2.1是否能运行 .net3.5 程序?我已经安装了 MONO 2.2

作者:陈龙   发布时间:09年02月18日   可选操作:删除 回复

[1楼] 回复:Jexus V2.1是否能运行 .net3.5 程序?

对Asp.net的支持程度是由Mono决定的。当前的Mono2.2版,已经完全支持 ASP.NET 2.0/3.0,同时也支持3.5的常用功能。
对具体的网站应用而言,你可以把网站传到服务器试一试,如果仅仅是极少的不兼容,你可以根据Mono的对应功能,略加修改就行了。当然,如果很多地方不兼容(这种情况是很少的),就不要迁移了。

作者:linuxdotnet   发布时间:09年02月18日   可选操作:删除 回复

[2楼] 回复:Jexus V2.1是否能运行 .net3.5 程序?

Operating system: Linux V2.6
.NET Framework Version: 2.0 (Mono)
Web Server: Jexus, V2.1
Uptime: 0 days, 0:15:3
这里是不是说没有在.net 3.5 下运行呢?
Mono JIT compiler version 2.2 (tarball Wed Feb 11 05:45:40 CST 2009)
Copyright (C) 2002-2008 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  x86
        Disabled:      none

作者:陈龙   发布时间:09年02月18日   可选操作:删除 回复

[3楼] 回复:Jexus V2.1是否能运行 .net3.5 程序?

[root@linux jws]# ./jws start
 * Jexus starting ... ./jws: line 37: start-stop-daemon: command not found
OK

用这个无法启动,报错

作者:陈龙   发布时间:09年02月18日   可选操作:删除 回复

[4楼] 回复:Jexus V2.1是否能运行 .net3.5 程序?

这说明你的系统中没有安装start-stop-daemon程序,解决方法之一是安装这个程序(这个程序比较重要),方法之二就是用 ./jws.start 这个脚本去启动,用jws.stop去停止.

作者:linuxdotnet   发布时间:09年02月18日   可选操作:删除 回复

 
   
   

留言回复:
标题: * 标题必填
作者:   * 请填上你的名字  
操作键:   * 填入几个字母表示是您写的,便于进一步操作
发言内容:
 
发贴者须知:
1、您无需注册即可发贴,但是,贴子内容必须在法律法规和社会公德所允许的范围内;
2、本站专注IT技术,谢绝包括政治、社会、情感等任何与IT技术无关的贴子在本站发表;
3、本站保留对任何贴子进行删除、禁用、更改、举报、追究等所有权利;
 
今天是: 周七  周一  周四  周三  周二  周五  周六